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CompassTA™ v2.50 Quick Start Guide – CompassTA Demo (Airport)

Purpose of this Document 

This document is meant to introduce the new or beginning user to CompassTA™ v2.3.  Its intent is that it be used as a 

guide to quickly open and use a set of known data to check the functionality of the newly installed CompassTA tool.  It 

can also give the user a snapshot of the process and features of the tool. 

How Does CompassTA™ v2.50 Benefit You?

 Automatically tests, verifies, and reports the accuracy of elevation data. It requires valid DEM data and ground 
control points that are the same map projection with common datum and spheroid.

 CompassTA™ v2.50 lets you test

 1.1 through 1.4 LiDAR point cloud data

 DEM data products

 Other raster elevation data such as IFSAR elevation data products.

 Makes available the PhotoBook tool for including up to 4 photos of cardinal points

 LiDAR Testing Extension, provides ‘dashboards’ for powerful and flexible LiDAR verification testing.

Conventional Steps to Use CompassTA™ v2.50

 Open new or existing project.

 Setup metadata by using Project Information/Add Project Information.

 Select Project Information/Add Index and Data Sources.

 Add the checkpoint .CSV file by selecting Project Information/Add Surveyed Locations.

 Explore differences by comparing surveyed locations with map elevation data.

 Set Land Cover Types.

 Generate Report(s).
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First Steps 

Open the CompassTA™ 2.50 application by clicking on the desktop icon.

Use the provided demo data (C:\CDIData\ CompassTA v2.4.1_LAS 1.4_Demo) that has been placed in the C:\CDIdata 

folder - by you, the user)  

***Optional *** To view the completed CompassTA QuickStart project, open CompassTA™, click on the menu 

command, File -> Open -> Project.  Navigate to C:\CDIData\ CompassTA v2.4.1_LAS 1.4_Demo\05_Reports, and select 

the CompassTA_Demo.TAP file. This .TAP (Topo Analyst Project) file contains the saved project data, created from the 

CompassTA v2.50 QuickStart instructions below.  (If queried about file existences click No and then go to Step 4 of this

QuickStart document about how to display a DEM image.)   

 The folder structure in the demo data sets is the structure we use in production and recommend.  However, CompassTA 

is a flexible tool and can be adapted to your own project data structure. 

Using CompassTA™ v2.50 for the first time

1. Double click on desktop icon CompassTA to open application.  Select File-> New-> Topo Data Project

2. Select Project Information-> Add Project Information

Fill in the data as suggested in the graphic below.  This becomes the metadata for the report.  The units that the report 

statistics will be calculated are set at this window. 

NOTE 

If at any given time you get an error window 

like below, please click on Continue and 

proceed with the operation of the tool. 

As a normal practice, it is always a good habit 

to save your work. 
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3. Select Project Information -> Add Index and Data Sources.  The window below should appear.  We will now add the

imagery and data files required.

3a. Select the Index File Name button and browse to the location below.  This is the location of the .shp (shapefile) that 

has the image index previously created.  This shapefile is found in the 01_DEM folder for this demo data.  Select and 

Open this .shp file. 

3b. After selecting the Index_File.shp file, click on the Select DEM Grids Field Name pull down menu.  This selection tells 

the program which column in the Tile Index contains the name of the images to be used.  

 For CompassTA™ there are three different Image types that can selected: LiDAR, DEM and LAS.  It is important to know 

which type of product is being used.   By clicking the View Table tab, the table below is displayed and the user can see 

which Field Name and what file format (e.g. .TIF, .SID) to select.  This Table is created and stored in the shapefile. 

For this demo, we are working with a DEM and IMAGENAME is selected as the DEM grid field name.  We are also 

demonstrating the new CompassTA v2.50 ability to handle LAS 1.4 files.  Select the LAS Field Name, LAS 1_4.  Click

Close on this Shape File Data window and select IMAGENAME from the drop down from Select DEM Grids Field Name.  

Next, select the LAS folder browse button.   
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3c.Referring back to the Add Index and data Sources window, select the DEMS Grids Folder button and browse to the 

folder that contains the images used for this demo.   Select the 01_DEM folder.  Click OK. 

3d. Click and the Select the Image Type on the Image Type pull down menu.  For this demo we are using TIF image files.  

Choose TIF for the file format. 
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3e.  The next selection is the Select Bare Earth Classification or Return Values.  In advanced projects this selection 

allows for different Land Classifications to be incorporated into the project.  For this demo and most standard elevation 

models, select Use All Points and click Save and then OK. 

3f.  Set CheckPoint Radial Search Distance for LAS Points has a default value of 10.  This defines the diameter that 

CompassTA will compare the current LAS point to other LAS points.  This can be adjusted as needed. 

3g.  Save Points/TINs/Results.  TIN’ing is not typically necessary.  Select No for this field. 

Click OK in the Add Tile Index and Images window.  The window should close and you should see the application window 

view above. 
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4. To view the images and ensure they were properly imported we can load the image into the view screen.  If

necessary, we can switch the visibility layer from LiDAR Intensity to DEM.  This switch can be made in the bottom right

corner of the program window.  You can then toggle back and forth to view the LAS 14 data and the DEM image.

Click Load Image in the upper left of the upper left of the application and then click inside the polygon.  The image 

should load. 

If zooming occurs during this process, clicking the View Full Extent Icon  to the right of the Pan blue hand icon.  It 

will display the full extent of the image being analyzed.  

You should now have your image displayed.  It is not necessary to have the images themselves displayed when doing 

your analysis. 

4a. Experiment with zooming, panning and viewing images using the interactive menu tools highlighted below.  These 

tools are useful to explore the images.  Try using more typical Windows adjustments using the mouse click and drag 

manipulations.  Move mouse over the perimeter boundary of the application window.  The mouse pointer will change to 

a respective resizing pointer that will allow you to stretch or shrink the application window.  Similar features for 

modifying the view ports inside the application window are adjustable too.  Grab the boundary edge between the Map 

Image area and the Coordinates and Offsets data display.  If the left button is held down, then you can make the map 

area bigger or smaller by dragging and releasing.  Always select the Full Extent graphic icon (magnifying glass) in the 
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main menu banner after resizing the map area to have the image refreshed to its maximum size for the new view port 

area 

When you are ready to go to the next step, click on the Zoom to Full Extent tool (the Magnifying Glass) to reset the 

image view.  

5. Save your project file to a .TAP (Topo Analyst Project) file for future use.  Select File -> Save As and then browse to the

05_Report folder location below and save the project to a file named CompassTA_Demo.TAP.

Input of Ground Control Data 

6. For the next step, we will add the survey ground control points using a .csv file.  Select Project Information -> Add

Surveyed Locations -> CSV File.  Browse to the 02_Check_Points folder location below and select the Airport Demo

Checkpoints_with_LAS_1.4_LC and Photos.csv file.

You will also find variations of the same data with and without photos and land classes.  These are for your use to 

explore CompassTA.  After selecting and opening the .csv file Airport Demo Checkpoints_with_LAS_1.4_LC and 

Photos.csv the window below should appear. 
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Let’s take a closer look at what is in the Airport Demo Checkpoints_with_LAS_1.4_LC and Photos.csv file. 

Because we are using a new CompassTA v2.50 ability to include photos with each point included with the final report

document, we need to include the unique name of each photo for each point.  These image files must be in a .jpg file 

type.  We also have listed the land classes based on the USGS LAS 1.4 standards.  (Note: there are not any sawgrass or 

mangrove swamps at the demo site.  All the land classes shown here are for demonstration purposes).  This is the 

recommended build of the .csv file.  You can customize your .csv as needed. 
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The .csv file is a critical element of CompassTA and a successful user needs to understand it.  Take time to look how this 

CompassTA Demo .csv file is set up and use it as an example for your own future projects.  The .csv lists records that 

correspond to file names found in the demo data sets.  Your file names don’t need to use the same CompassData 

naming convention as shown, but a unique, identifying name should be used. 

6a. Select the applicable fields to match the proper columns.  Remember, Northing is always the Y axis and Easting is 

always the X axis.  Switching these is a common error.  Make sure to select the Ignore First Row radio button if there is 

header information in the .csv file. 

6b. After confirming that the columns of data are selected as in the graphic above click OK again.  The application 

window should appear as below.  Click Yes to begin calculating the elevation difference between the DEM, LAS data and 

the elevations associated with the ground control points in the .csv. 

Using Photo Book 

7. Now, we will photo identify a point and use the provided tools to create a report.

If you have saved your work before, then do so again by clicking File -> Save. 
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7a. Use the Zoom Factor (ZF) slide bar to adjust the zoom.  You can also type in the Current Scale by clicking on the 

value and entering 1500.  (For this demo, 1:1500 is a good scale for reviewing points.)  Now left click on the Save 

Context Extent button on the right to stay at the same scale while going from point to point. 

Select Photo Book from the application command menu.  As you click through the different ground control points in the 

Coordinates and Offset table photos in the Photo Book will update itself to match the selected point.  The main screen 

image will also swap out to match the ground control point selected.  These photos were input using the .CSV file. 

Unlike CompassAA, the CompassTA report will not include a scaled overhead view of the ground control point.  It does 

place photos of the four cardinal compass points and labels them in that manner. 
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7b. At this point it is good idea to check that the check points and images are in the same coordinate system, that the 

check points are all within appropriate areas of the image and that none of the check points are damaged. 

This is accomplished by panning to the right in the Coordinates and Offsets window and looking at the ΔZ DEM and ΔZ 

LAS column.  It depends on the quality of the elevation model being used, but these values should make sense; 3,000 

feet off could be an elevation conversion issue and not a problem with the DEM or LAS data.  Along the edges of the 

images the data associated with the image is often corrupted, leading to a poor ΔZ DEM value.  This is also a good time 

to find mistakes made when creating DEM’s (holes, large elevation spikes).  When ΔZ DEM or ΔZ LAS values don’t make 

sense, look at the point itself in the image and the photos.  Any points that are not helping the processing for whatever 

reason can be removed from the calculations.  Click on the check mark box and then select a reason for not using the 

point.  A list of the points excluded in the analysis, and the reason for their exclusion, can be included in the final report. 

8. The next step is to calculate the Error Statistics.  A few settings require updating before this can be done.  For DEMs

or LAS, make sure NVA radio button is selected, make sure the box next to ALL is checked and Select LiDAR Intensity

from the Visibility Layer drop down menu.  Select Calculate.   The accuracy fields will automatically populate.

8a. This is a good point to save your project data.  Select File -> Save to save the current project into the 05_Report 

folder. 
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If there is a need to deliver data in another format (FVA, SVA and CVA) it is possible to switch back to that LAS Land 

Cover type method.  Select Tools -> Options from the main application menu. 

There is also LAS 1.1 data as part of the demo data to experiment with the FVA, SVA and CVA type of data.  This lets you 

try a LAS 1.1 data set following a similar process as with LAS 1.4 data. 

While the Options window is open, let’s look at how we can edit the Land Class type labels.  Select the tab labeled Land 

Cover.  There are seven Land Classifications specified by the USGS LAS 1.4 standard that can be customized. 
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Selecting Land Cover types 

9. The next step will let us set the land cover types for project LAS and DEM data.  CompassTA requires this step to be

performed prior to creating a report.  Select Tools -> Set LCs.  For the purposes of this exercise, please select the LAS

and then the DEM tab in the upper left corner of the window named Land Cover Types & Tests.  Click on the

appropriate NVA and VVA radio buttons as shown in the window below.  Click on Save in the lower right corner of the

window.

Creating a CompassTA Data Verification and Validation Report 

10. We can now create a report.  Select Tools -> Report from the application menu.

A company or project logo can be easily added to the report.  When finished, click on the Save button. 
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10a. Browse to the 05_Reports folder location shown above and Save the report to CompassTA 

v2.4.1_LAS_1.4_Demo.pdf.  The .pdf file will either open automatically or you will need to browse to its saved 

05_Reports folder location and double click on it. 

Congratulations! 

You have now successfully used CompassTA v2.50 as a solution to verify the accuracy and quality of DEM data.  You
verified the DEM and LAS 1.4 data by using collected control points.  Lastly, you created a custom, meaningful report 
verifying DEM and LAS accuracy. 

mailto:accuracytools@compassdatainc.com



